13 lines
400 B
Nix
13 lines
400 B
Nix
(import
|
|
(
|
|
# Get corresponding version of flake-compat declared in on ./flake.lock
|
|
let lock = builtins.fromJSON (builtins.readFile ./flake.lock); in
|
|
fetchTarball {
|
|
url = "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
|
|
sha256 = lock.nodes.flake-compat.locked.narHash;
|
|
}
|
|
)
|
|
{ src = ./.; } # calls flake.nix
|
|
).defaultNix
|
|
|