44 lines
1.5 KiB
Nix
44 lines
1.5 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ config, lib, pkgs, modulesPath, ... }:
|
||
|
||
{
|
||
imports =
|
||
[
|
||
(modulesPath + "/profiles/qemu-guest.nix")
|
||
];
|
||
|
||
boot.initrd.availableKernelModules = [ "virtio_pci" "virtio_scsi" "ahci" "sd_mod" ];
|
||
boot.initrd.kernelModules = [ ];
|
||
boot.kernelParams = [ "console=ttyS0,19200n8" ];
|
||
boot.loader.grub.extraConfig = ''
|
||
serial --speed=19200 --unit=0 --word=8 --parity=no --stop=1
|
||
terminal_input serial;
|
||
terminal_output serial
|
||
'';
|
||
boot.loader.grub.forceInstall = true;
|
||
boot.loader.grub.device = "nodev";
|
||
boot.loader.timeout = 10;
|
||
boot.kernelModules = [ ];
|
||
boot.extraModulePackages = [ ];
|
||
|
||
fileSystems."/" =
|
||
{
|
||
device = "/dev/sda";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
swapDevices =
|
||
[{ device = "/dev/sdb"; }];
|
||
|
||
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
||
# (the default) this is the recommended approach. When using systemd-networkd it's
|
||
# still possible to use this option, but it's recommended to use it in conjunction
|
||
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
|
||
networking.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.enp0s5.useDHCP = lib.mkDefault true;
|
||
|
||
hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
||
}
|